perl-Pod-Cpandoc-0.160.0-2.mga7.noarch.rpm


Advertisement

Description

perl-Pod-Cpandoc - Perldoc that works for modules you don't have installed

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename perl-Pod-Cpandoc-0.160.0-2.mga7.noarch.rpm
Package name perl-Pod-Cpandoc
Package version 0.160.0
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Pod-Cpandoc
License GPL+ or Artistic
Maintainer -
Download size 16.32 KB
Installed size 16.72 KB
'cpandoc' is a perl script that acts like 'perldoc' except that if it would
have bailed out with 'No documentation found for "Uninstalled::Module"', it
will instead scrape a CPAN index for the module's documentation.
One important feature of 'cpandoc' is that it _only_ scrapes the live index
if you do not have the module installed. So if you use 'cpandoc' on a
module you already have installed, then it will just read the
already-installed documentation. This means that the version of the
documentation matches up with the version of the code you have. As a fringe
benefit, 'cpandoc' will be fast for modules you've installed. :)
All this means that you should be able to drop in 'cpandoc' in place of
'perldoc' and have everything keep working. See the /SNEAKY INSTALL manpage
for how to do this.

Alternatives

Package Version Architecture Repository
perl-Pod-Cpandoc-0.160.0-2.mga7.noarch.rpm 0.160.0 noarch Mageia Core
perl-Pod-Cpandoc - - -

Requires

Name Value
perl >= 1:5.8.1
perl(File::Temp) -
perl(HTTP::Tiny) -
perl(IO::Socket::SSL) >= 1.560.0
perl(JSON::PP) -
perl(Net::SSLeay) >= 1.490.0
perl(Pod::Cpandoc) -
perl(Pod::Perldoc) -
perl(base) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.28.0

Provides

Name Value
perl(Pod::Cpandoc) == 0.160.0
perl-Pod-Cpandoc == 0.160.0-2.mga7

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-Pod-Cpandoc-0.160.0-2.mga7.noarch.rpm
Source Package perl-Pod-Cpandoc-0.160.0-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Pod-Cpandoc rpm package:
    # urpmi perl-Pod-Cpandoc

Files

Path
/usr/bin/cpandoc
/usr/share/doc/perl-Pod-Cpandoc/Changes
/usr/share/doc/perl-Pod-Cpandoc/META.yml
/usr/share/doc/perl-Pod-Cpandoc/MYMETA.yml
/usr/share/doc/perl-Pod-Cpandoc/README
/usr/share/man/man1/cpandoc.1.xz
/usr/share/man/man3/Pod::Cpandoc.3pm.xz
/usr/share/perl5/vendor_perl/Pod/Cpandoc.pm

Changelog

2018-09-20 - umeabot <umeabot> 0.160.0-2.mga7
(not released yet)
+ Revision: 1285739
- Mageia 7 Mass Rebuild
2017-07-28 - sander85 <sander85> 0.160.0-1.mga7
+ Revision: 1132129
- update to 0.16
2016-06-19 - pterjan <pterjan> 0.150.0-6.mga6
+ Revision: 1032279
- Rebuild for perl 5.22.2
2016-02-05 - umeabot <umeabot> 0.150.0-5.mga6
+ Revision: 936535
- Mageia 6 Mass Rebuild

See Also

Package Description
perl-Pod-Elemental-0.103.4-4.mga7.noarch.rpm A Pod =command element
perl-Pod-Elemental-MakeSelector-0.120.0-3.mga7.noarch.rpm Build complex selectors as a single sub
perl-Pod-Elemental-PerlMunger-0.200.6-2.mga7.noarch.rpm A thing that takes a string of Perl and rewrites its documentation
perl-Pod-Elemental-Transformer-List-0.102.0-7.mga7.noarch.rpm Transform :list regions into =over/=back to save typing
perl-Pod-Elemental-Transformer-Verbatim-0.1.0-3.mga7.noarch.rpm Transform :verbatim regions into verbatim paragraphs
perl-Pod-Elemental-Transformer-WikiDoc-0.93.4-4.mga7.noarch.rpm A transformer to replace "wikidoc" data regions with Pod5 elements
perl-Pod-Escapes-1.70.0-4.mga7.noarch.rpm Perl module to resolve Pod E<...> sequences
perl-Pod-Eventual-0.94.1-8.mga7.noarch.rpm Just get an array of the stuff Pod::Eventual finds
perl-Pod-Generated-0.50.0-9.mga7.noarch.rpm Template plugin to help generate POD
perl-Pod-HTML2Pod-4.50.0-7.mga7.noarch.rpm Translate HTML into POD
perl-Pod-HtmlEasy-1.1.11-6.mga7.noarch.rpm Generate personalized HTML from PODs
perl-Pod-LaTeX-0.610.0-13.mga7.noarch.rpm Converts pod to latex with Pod::Parser
perl-Pod-Loom-0.80.0-7.mga7.noarch.rpm Do-nothing template for Pod::Loom
perl-Pod-Markdown-3.200.0-1.mga8.noarch.rpm Convert POD to Markdown
perl-Pod-Markdown-Github-0.40.0-1.mga7.noarch.rpm Convert POD to Github's specific markdown
Advertisement
Advertisement