python3-blockdev-2.20-6.mga8.i586.rpm


Advertisement

Description

python3-blockdev - Python3 gobject-introspection bindings for libblockdev

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename python3-blockdev-2.20-6.mga8.i586.rpm
Package name python3-blockdev
Package version 2.20
Package release 6.mga8
Package architecture i586
Package type rpm
Category Development/Python
Homepage https://github.com/storaged-project/libblockdev
License LGPLv2+
Maintainer -
Download size 36.90 KB
Installed size 79.97 KB
This package contains enhancements to the gobject-introspection bindings for
libblockdev in Python3.

Alternatives

Package Version Architecture Repository
python3-blockdev-2.20-6.mga8.x86_64.rpm 2.20 x86_64 Mageia Core
python3-blockdev - - -

Requires

Name Value
libblockdev-gir2.0(x86-32) == 2.20-6.mga8
libblockdev2(x86-32) == 2.20-6.mga8
python(abi) == 3.8
python3-gobject3 -
typelib(GLib) -

Provides

Name Value
python-blockdev == 2.20-6.mga8
python3-blockdev == 2.20-6.mga8
python3-blockdev(x86-32) == 2.20-6.mga8

Obsoletes

Name Value
python-blockdev < 2.20-6.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python3-blockdev-2.20-6.mga8.i586.rpm
Source Package libblockdev-2.20-6.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install python3-blockdev rpm package:
    # urpmi python3-blockdev

Files

Path
/usr/lib/python3.8/site-packages/gi/overrides/BlockDev.py
/usr/lib/python3.8/site-packages/gi/overrides/__pycache__/BlockDev.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/gi/overrides/__pycache__/BlockDev.cpython-38.pyc

Changelog

2019-09-21 - daviddavid <daviddavid> 2.20-6.mga8
+ Revision: 1444413
- rebuild for python3.8
2019-02-05 - tv <tv> 2.20-5.mga7
+ Revision: 1363376
- fix broken deps
2019-01-26 - ngompa <ngompa> 2.20-4.mga7
+ Revision: 1361166
- Fix version constraints across subpackages
2019-01-26 - ngompa <ngompa> 2.20-3.mga7
+ Revision: 1361065
- Adapt for Mageia from Fedora
- imported package libblockdev
2018-10-08 - Vojtech Trefny <vtrefny@redhat.com> - 2.20-2
- Use libblkid to check swap status before swapon (vtrefny)
- Add error codes and Python exceptions for swapon fails (vtrefny)
2018-09-26 - Vojtech Trefny <vtrefny@redhat.com> - 2.20-1
- Use unsafe caching for storage for devel/testing VMs (v.podzimek)
- Require newer version of cryptsetup for LUKS2 tests (vtrefny)
- Skip nvdimm tests on systems without ndctl (vtrefny)
- Add Ubuntu 18.04 VM configuration to the vagrant template (vtrefny)
- Add some missing test dependencies to the vagrant template (vtrefny)
- Fix how/where the bcache tests are skipped (v.podzimek)
- Document what the 'misc' directory contains (v.podzimek)
- Add a Vagrantfile template (v.podzimek)
- Fix the error message when deleting partition fails (vpodzime)
- Fix build of plugins by changing linking order (devurandom)
- Fix how we check zram stats from /sys/block/zram0/stat (vtrefny)
- lvm-dbus: Fix parsing extra arguments for LVM methods calls (vtrefny)
- Skip MDTestAddRemove on Debian (vtrefny)
- Skip NTFS mount test on Debian testing (vtrefny)
- Skip bcache tests on Debian testing (vtrefny)
- tests: Try harder to get distribution version (vtrefny)
- Mark the function stubs as static (v.podzimek)
- Build the dm plugin without dmraid support on newer RHEL (vtrefny)
- Fix skipping zram tests on Fedora 27 (vtrefny)
- kbd: Check for zram module availability in 'bd_kbd_is_tech_avail' (vtrefny)
- Always build the VDO plugin (vtrefny)
- Do not require 'dmraid' package if built without dmraid support (vtrefny)
- Fix licence header in dbus.c (vtrefny)
- Fix spacing in NEWS.rst (vtrefny)

See Also

Package Description
python3-booleanoperations-0.8.2-3.mga8.noarch.rpm Boolean operations on paths
python3-boost-openmpi-1.68.0-7.mga8.i586.rpm Python 3 bindings for Boost.MPI-OpenMPI library
python3-botan-1.10.17-9.mga8.i586.rpm Python3 bindings for botan
python3-botan2-2.12.1-1.mga8.i586.rpm Python3 bindings for botan2
python3-boto-2.49.0-2.mga8.noarch.rpm A simple lightweight interface to Amazon Web Services
python3-boto3-1.10.21-1.mga8.noarch.rpm The AWS SDK for Python 3
python3-botocore-1.13.21-1.mga8.noarch.rpm The low-level, core functionality of boto 3
python3-bottle-0.12.17-1.mga8.noarch.rpm Fast and simple WSGI-framework for small web-applications
python3-bottleneck-1.2.1-3.mga8.i586.rpm Fast NumPy array functions written in C
python3-brlapi-5.5-8.mga8.i586.rpm Python 3 bindings for BrlAPI
python3-brotli-1.0.7-3.mga8.i586.rpm Python3 module for brotli
python3-brotlipy-0.7.0-4.mga8.i586.rpm Python 3 binding to the Brotli library
python3-bsddb3-6.2.6-5.mga8.i586.rpm Python 3 bindings for BerkeleyDB
python3-bson-3.8.0-3.mga8.i586.rpm Python 3 bson library
python3-bugzilla-2.2.0-4.mga8.noarch.rpm A python 3 library for interacting with Bugzilla
Advertisement
Advertisement