ruby-launchy-2.4.3-2.mga7.noarch.rpm


Advertisement

Description

ruby-launchy - Helper class for launching cross-platform applications

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename ruby-launchy-2.4.3-2.mga7.noarch.rpm
Package name ruby-launchy
Package version 2.4.3
Package release 2.mga7
Package architecture noarch
Package type rpm
Category Development/Ruby
Homepage http://copiousfreetime.rubyforge.org/launchy/
License ISC License
Maintainer -
Download size 35.88 KB
Installed size 84.94 KB
Launchy is helper class for launching cross-platform applications in a
fire and forget manner.
There are application concepts (browser, email client, etc) that are
common across all platforms, and they may be launched differently on
each platform.  Launchy is here to make a common approach to launching
external application from within ruby programs.

Alternatives

Package Version Architecture Repository
ruby-launchy-2.4.3-2.mga7.noarch.rpm 2.4.3 noarch Mageia Core
ruby-launchy - - -

Requires

Name Value
ruby(rubygems) -
rubygem(addressable) >= 2.3
rubygem(addressable) < 3

Provides

Name Value
ruby-launchy == 2.4.3-2.mga7
rubygem(launchy) == 2.4.3-1

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package ruby-launchy-2.4.3-2.mga7.noarch.rpm
Source Package ruby-launchy-2.4.3-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-launchy rpm package:
    # urpmi ruby-launchy

Files

Path
/usr/bin/launchy
/usr/share/gems/gems/launchy-2.4.3/CONTRIBUTING.md
/usr/share/gems/gems/launchy-2.4.3/HISTORY.md
/usr/share/gems/gems/launchy-2.4.3/LICENSE
/usr/share/gems/gems/launchy-2.4.3/Manifest.txt
/usr/share/gems/gems/launchy-2.4.3/README.md
/usr/share/gems/gems/launchy-2.4.3/Rakefile
/usr/share/gems/gems/launchy-2.4.3/bin/launchy
/usr/share/gems/gems/launchy-2.4.3/lib/launchy.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/application.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/argv.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/cli.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/deprecated.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/descendant_tracker.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/detect.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/error.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/os_family.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/version.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/applications/browser.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/detect/host_os.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/detect/host_os_family.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/detect/nix_desktop_environment.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/detect/ruby_engine.rb
/usr/share/gems/gems/launchy-2.4.3/lib/launchy/detect/runner.rb
/usr/share/gems/gems/launchy-2.4.3/spec/application_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/cli_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/launchy_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/mock_application.rb
/usr/share/gems/gems/launchy-2.4.3/spec/spec_helper.rb
/usr/share/gems/gems/launchy-2.4.3/spec/tattle-host-os.yaml
/usr/share/gems/gems/launchy-2.4.3/spec/version_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/applications/browser_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/detect/host_os_family_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/detect/host_os_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/detect/nix_desktop_environment_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/detect/ruby_engine_spec.rb
/usr/share/gems/gems/launchy-2.4.3/spec/detect/runner_spec.rb
/usr/share/gems/gems/launchy-2.4.3/tasks/default.rake
/usr/share/gems/gems/launchy-2.4.3/tasks/this.rb
/usr/share/gems/specifications/launchy-2.4.3.gemspec

Changelog

2018-09-19 - umeabot <umeabot> 2.4.3-2.mga7
(not released yet)
+ Revision: 1275143
- Mageia 7 Mass Rebuild
2016-01-04 - pterjan <pterjan> 2.4.3-1.mga6
+ Revision: 919692
- Update to 2.4.3

See Also

Package Description
ruby-launchy-doc-2.4.3-2.mga7.noarch.rpm Documentation for ruby-launchy
ruby-less-2.6.0-2.mga7.noarch.rpm LESS is leaner CSS
ruby-less-doc-2.6.0-2.mga7.noarch.rpm Documentation for ruby-less
ruby-libguestfs-1.40.2-1.mga8.i586.rpm Ruby bindings for libguestfs
ruby-libvirt-0.5.2-8.mga7.i586.rpm Ruby bindings for libvirt
ruby-libwebsocket-0.1.8-2.mga7.noarch.rpm A universal Ruby library to handle the WebSocket protocol
ruby-libwebsocket-doc-0.1.8-2.mga7.noarch.rpm Documentation for ruby-libwebsocket
ruby-libxml-2.8.0-6.mga7.i586.rpm Ruby libxml bindings
ruby-libxml-doc-2.8.0-6.mga7.i586.rpm Documentation for ruby-libxml
ruby-liquid-4.0.1-1.mga7.noarch.rpm A secure, non-evaling end user template engine with aesthetic markup
ruby-liquid-doc-4.0.1-1.mga7.noarch.rpm Documentation for ruby-liquid
ruby-listen-3.1.5-2.mga7.noarch.rpm Ruby module to listen to file modifications
ruby-listen-doc-3.1.5-2.mga7.noarch.rpm Documentation for ruby-listen
ruby-little-plugger-1.1.4-2.mga7.noarch.rpm LittlePlugger is a module that provides Gem based plugin management
ruby-little-plugger-doc-1.1.4-2.mga7.noarch.rpm Documentation for ruby-little-plugger
Advertisement
Advertisement