ruby-rbx-require-relative-0.0.9-9.mga6.noarch.rpm


Advertisement

Description

ruby-rbx-require-relative - Fast Ruby debugger - core component

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name ruby-rbx-require-relative
Package version 0.0.9
Package release 9.mga6
Package architecture noarch
Package type rpm
Installed size 14.12 KB
Download size 14.23 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Ruby 1.9's require_relative for Rubinius and MRI 1.8. We also add
abs_path which is like __FILE__ but __FILE__ can be fooled by a sneaky
"chdir" while abs_path can't. If you are running on Ruby 1.9 or greater,
require_relative is the pre-defined version. The benefit we provide in
this situation by this package is the ability to write the same
require_relative sequence in Rubinius 1.8 and Ruby 1.9.

Alternatives

Package Version Architecture Repository
ruby-rbx-require-relative-0.0.9-9.mga6.noarch.rpm 0.0.9 noarch Mageia Core
ruby-rbx-require-relative - - -

Requires

Name Value
ruby(rubygems) -

Provides

Name Value
ruby-rbx-require-relative == 0.0.9-9.mga6
rubygem(rbx-require-relative) == 0.0.9-1

Download

Type URL
Binary Package ruby-rbx-require-relative-0.0.9-9.mga6.noarch.rpm
Source Package ruby-rbx-require-relative-0.0.9-9.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-rbx-require-relative rpm package:
    # urpmi ruby-rbx-require-relative

Files

Path
/usr/share/gems/gems/rbx-require-relative-0.0.9/ChangeLog
/usr/share/gems/gems/rbx-require-relative-0.0.9/LICENSE
/usr/share/gems/gems/rbx-require-relative-0.0.9/NEWS
/usr/share/gems/gems/rbx-require-relative-0.0.9/README.textile
/usr/share/gems/gems/rbx-require-relative-0.0.9/Rakefile
/usr/share/gems/gems/rbx-require-relative-0.0.9/lib/require_relative.rb
/usr/share/gems/gems/rbx-require-relative-0.0.9/lib/version.rb
/usr/share/gems/gems/rbx-require-relative-0.0.9/test/bar.rb
/usr/share/gems/gems/rbx-require-relative-0.0.9/test/foo.rb
/usr/share/gems/gems/rbx-require-relative-0.0.9/test/test-rr.rb
/usr/share/gems/specifications/rbx-require-relative-0.0.9.gemspec

Changelog

2016-02-17 - umeabot <umeabot> 0.0.9-9.mga6
+ Revision: 963830
- Mageia 6 Mass Rebuild
2014-10-15 - umeabot <umeabot> 0.0.9-8.mga5
+ Revision: 739996
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.0.9-7.mga5
+ Revision: 688924
- Mageia 5 Mass Rebuild
2013-12-28 - pterjan <pterjan> 0.0.9-6.mga4
+ Revision: 562423
- Fix gem macros
2013-10-21 - umeabot <umeabot> 0.0.9-4.mga4
+ Revision: 538928
- Mageia 4 Mass Rebuild
2013-10-04 - fwang <fwang> 0.0.9-3.mga4
+ Revision: 491114
- update file list
- update file list
- use gem_setup

See Also

Package Description
ruby-rbx-require-relative-doc-0.0.9-9.mga6.noarch.rpm Documentation for ruby-rbx-require-relative
ruby-rchardet-1.8.0-1.mga7.noarch.rpm Character encoding auto-detection in Ruby
ruby-rchardet-doc-1.8.0-1.mga7.noarch.rpm Documentation for ruby-rchardet
ruby-rdiscount-2.2.0.1-2.mga7.i586.rpm Fast Implementation of Gruber's Markdown in C
ruby-rdiscount-doc-2.2.0.1-2.mga7.noarch.rpm Documentation for ruby-rdiscount
ruby-rdoc-6.0.4-1.mga7.noarch.rpm RDoc produces HTML and command-line documentation for Ruby projects
ruby-rdoc-doc-6.0.4-1.mga7.noarch.rpm Documentation for ruby-rdoc
ruby-redland-1.0.17.1-5.mga7.i586.rpm Ruby modules for the Redland RDF library
ruby-representable-3.0.4-1.mga7.noarch.rpm Renders and parses JSON/XML/YAML documents from and to Ruby objects. Includes plain properties, collections, nesting, coercion and more
ruby-representable-doc-3.0.4-1.mga7.noarch.rpm Documentation for ruby-representable
ruby-rest-client-2.0.2-1.mga7.noarch.rpm A simple HTTP and REST client for Ruby
ruby-rest-client-doc-2.0.2-1.mga7.noarch.rpm Documentation for ruby-rest-client
ruby-retriable-3.1.2-1.mga7.noarch.rpm Retriable is an simple DSL to retry failed code blocks with randomized exponential backoff
ruby-retriable-doc-3.1.2-1.mga7.noarch.rpm Documentation for ruby-retriable
ruby-rexical-1.0.5-9.mga6.noarch.rpm Rexical is a lexical scanner generator
Advertisement
Advertisement