ruby-semantic_puppet-1.0.2-1.mga7.noarch.rpm


Advertisement

Description

ruby-semantic_puppet - Useful tools for working with Semantic Versions

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package filename ruby-semantic_puppet-1.0.2-1.mga7.noarch.rpm
Package name ruby-semantic_puppet
Package version 1.0.2
Package release 1.mga7
Package architecture noarch
Package type rpm
Category Development/Ruby
Homepage https://github.com/puppetlabs/semantic_puppet-gem
License Apache-2.0
Maintainer -
Download size 35.97 KB
Installed size 139.13 KB
Tools used by Puppet to parse, validate, and compare Semantic Versions and
Version Ranges and to query and resolve module dependencies.

Alternatives

Package Version Architecture Repository
ruby-semantic_puppet-1.0.2-1.mga7.noarch.rpm 1.0.2 noarch Mageia Core
ruby-semantic_puppet - - -

Requires

Name Value
ruby(rubygems) -

Provides

Name Value
ruby-semantic_puppet == 1.0.2-1.mga7
rubygem(semantic_puppet) == 1.0.2
rubygem(semantic_puppet) == 1.0.2-1

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package ruby-semantic_puppet-1.0.2-1.mga7.noarch.rpm
Source Package ruby-semantic_puppet-1.0.2-1.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-semantic_puppet rpm package:
    # urpmi ruby-semantic_puppet

Files

Path
/usr/share/gems/gems/semantic_puppet-1.0.2/.gitignore
/usr/share/gems/gems/semantic_puppet-1.0.2/.rubocop.yml
/usr/share/gems/gems/semantic_puppet-1.0.2/.travis.yml
/usr/share/gems/gems/semantic_puppet-1.0.2/.yardopts
/usr/share/gems/gems/semantic_puppet-1.0.2/CHANGELOG.md
/usr/share/gems/gems/semantic_puppet-1.0.2/Gemfile
/usr/share/gems/gems/semantic_puppet-1.0.2/LICENSE
/usr/share/gems/gems/semantic_puppet-1.0.2/README.md
/usr/share/gems/gems/semantic_puppet-1.0.2/Rakefile
/usr/share/gems/gems/semantic_puppet-1.0.2/appveyor.yml
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/dependency.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/gem_version.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/version.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/version_range.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/dependency/graph.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/dependency/graph_node.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/dependency/module_release.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/dependency/source.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/lib/semantic_puppet/dependency/unsatisfiable_graph.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/spec_helper.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/dependency_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/version_range_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/version_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/dependency/graph_node_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/dependency/graph_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/dependency/module_release_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/dependency/source_spec.rb
/usr/share/gems/gems/semantic_puppet-1.0.2/spec/unit/semantic_puppet/dependency/unsatisfiable_graph_spec.rb
/usr/share/gems/specifications/semantic_puppet-1.0.2.gemspec

Changelog

2019-01-26 - guillomovitch <guillomovitch> 1.0.2-1.mga7
+ Revision: 1361087
- imported package ruby-semantic_puppet

See Also

Package Description
ruby-semantic_puppet-doc-1.0.2-1.mga7.noarch.rpm Documentation for ruby-semantic_puppet
ruby-sexp_processor-4.11.0-2.mga7.noarch.rpm Branches from ParseTree bringing all the generic sexp processing tools with it
ruby-sexp_processor-doc-4.11.0-2.mga7.noarch.rpm Documentation for ruby-sexp_processor
ruby-shoulda-context-1.2.2-2.mga7.noarch.rpm Context framework extracted from Shoulda
ruby-shoulda-context-doc-1.2.2-2.mga7.noarch.rpm Documentation for ruby-shoulda-context
ruby-signet-0.11.0-1.mga7.noarch.rpm Signet is an OAuth 1.0 / OAuth 2.0 implementation
ruby-signet-doc-0.11.0-1.mga7.noarch.rpm Documentation for ruby-signet
ruby-simplecov-0.16.1-2.mga7.noarch.rpm Code coverage for Ruby 1.9 with a powerful configuration library
ruby-simplecov-doc-0.16.1-2.mga7.noarch.rpm Documentation for ruby-simplecov
ruby-simplecov-html-0.10.2-2.mga7.noarch.rpm Default HTML formatter for SimpleCov code coverage tool for ruby 1.9+
ruby-simplecov-html-doc-0.10.2-2.mga7.noarch.rpm Documentation for ruby-simplecov-html
ruby-sinatra-2.0.5-2.mga7.noarch.rpm Classy web-development dressed in a DSL
ruby-sinatra-contrib-2.0.5-1.mga7.noarch.rpm Collection of useful Sinatra extensions
ruby-sinatra-contrib-doc-2.0.5-1.mga7.noarch.rpm Documentation for ruby-sinatra-contrib
ruby-slop-4.6.2-2.mga7.noarch.rpm A simple DSL for gathering options and parsing the command line
Advertisement
Advertisement