ruby-wrongdoc-1.8.1-2.mga6.noarch.rpm


Advertisement

Description

ruby-wrongdoc - RDoc done right (IMNSHO)

Property Value
Distribution Mageia Cauldron
Repository Mageia Core i586
Package name ruby-wrongdoc
Package version 1.8.1
Package release 2.mga6
Package architecture noarch
Package type rpm
Installed size 115.08 KB
Download size 47.34 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
wrongdoc mangles an existing RDoc directory and makes any changes we feel like.
It mainly removes JavaScript from Darkfish and adds links to a cgit instance.
It is a bikeshed project and *entirely* subject to the whims of its creator,
so it is likely the wrong solution for anybody else.

Alternatives

Package Version Architecture Repository
ruby-wrongdoc-1.8.1-2.mga6.noarch.rpm 1.8.1 noarch Mageia Core
ruby-wrongdoc - - -

Requires

Name Value
ruby -
ruby(rubygems) -
rubygem(nokogiri) >= 1.5
rubygem(nokogiri) < 2
rubygem(rdoc) >= 3.9
rubygem(tidy_ffi) >= 0.1
rubygem(tidy_ffi) >= 0.1.5
rubygem(tidy_ffi) < 1

Provides

Name Value
ruby-wrongdoc == 1.8.1-2.mga6
rubygem(wrongdoc) == 1.8.1-1

Download

Type URL
Binary Package ruby-wrongdoc-1.8.1-2.mga6.noarch.rpm
Source Package ruby-wrongdoc-1.8.1-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-wrongdoc rpm package:
    # urpmi ruby-wrongdoc

Files

Path
/usr/bin/wrongdoc
/usr/share/gems/gems/wrongdoc-1.8.1/.document
/usr/share/gems/gems/wrongdoc-1.8.1/.gitignore
/usr/share/gems/gems/wrongdoc-1.8.1/.manifest
/usr/share/gems/gems/wrongdoc-1.8.1/.wrongdoc.yml
/usr/share/gems/gems/wrongdoc-1.8.1/COPYING
/usr/share/gems/gems/wrongdoc-1.8.1/ChangeLog
/usr/share/gems/gems/wrongdoc-1.8.1/GIT-VERSION-FILE
/usr/share/gems/gems/wrongdoc-1.8.1/GIT-VERSION-GEN
/usr/share/gems/gems/wrongdoc-1.8.1/GNUmakefile
/usr/share/gems/gems/wrongdoc-1.8.1/LATEST
/usr/share/gems/gems/wrongdoc-1.8.1/LICENSE
/usr/share/gems/gems/wrongdoc-1.8.1/NEWS
/usr/share/gems/gems/wrongdoc-1.8.1/README
/usr/share/gems/gems/wrongdoc-1.8.1/dotwrongdoc_5
/usr/share/gems/gems/wrongdoc-1.8.1/pkg.mk
/usr/share/gems/gems/wrongdoc-1.8.1/setup.rb
/usr/share/gems/gems/wrongdoc-1.8.1/wrongdoc.sh
/usr/share/gems/gems/wrongdoc-1.8.1/wrongdoc_1
/usr/share/gems/gems/wrongdoc-1.8.1/Documentation/.gitignore
/usr/share/gems/gems/wrongdoc-1.8.1/Documentation/GNUmakefile
/usr/share/gems/gems/wrongdoc-1.8.1/Documentation/dotwrongdoc.5.ronn
/usr/share/gems/gems/wrongdoc-1.8.1/Documentation/wrongdoc.1.ronn
/usr/share/gems/gems/wrongdoc-1.8.1/bin/wrongdoc
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/changelog.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/final.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/gemspec.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/history.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/merge.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/news_atom.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/news_rdoc.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/parse_xml.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/prepare.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/rdoc.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/rdoc_options.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/readme.rb
/usr/share/gems/gems/wrongdoc-1.8.1/lib/wrongdoc/release.rb
/usr/share/gems/gems/wrongdoc-1.8.1/man/
/usr/share/gems/gems/wrongdoc-1.8.1/man/man1/wrongdoc.1
/usr/share/gems/gems/wrongdoc-1.8.1/man/man5/dotwrongdoc.5
/usr/share/gems/specifications/wrongdoc-1.8.1.gemspec

Changelog

2016-04-15 - daviddavid <daviddavid> 1.8.1-2.mga6
+ Revision: 1001597
- add a patch to fix dependency on ruby-rdoc
2016-02-14 - pterjan <pterjan> 1.8.1-1.mga6
+ Revision: 960135
- Update to 1.8.1
2015-12-19 - pterjan <pterjan> 1.7.0-8.mga6
+ Revision: 912323
- Rebuild for ruby 2.2
2015-10-21 - pterjan <pterjan> 1.7.0-7.mga6
+ Revision: 893718
- Fix the package to be noarch
2014-10-15 - umeabot <umeabot> 1.7.0-6.mga5
+ Revision: 748219
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 1.7.0-5.mga5
+ Revision: 689001
- Mageia 5 Mass Rebuild
2013-12-28 - pterjan <pterjan> 1.7.0-4.mga4
+ Revision: 562648
- Fix gem macros
2013-10-21 - umeabot <umeabot> 1.7.0-3.mga4
+ Revision: 538167
- Mageia 4 Mass Rebuild
2013-09-20 - pterjan <pterjan> 1.7.0-2.mga4
+ Revision: 482372
- Rebuild for Ruby 2
2013-09-15 - pterjan <pterjan> 1.7.0-1.mga4
+ Revision: 479979
- imported package ruby-wrongdoc

See Also

Package Description
ruby-wrongdoc-doc-1.8.1-2.mga6.noarch.rpm Documentation for ruby-wrongdoc
ruby-xml-simple-1.1.5-1.mga6.noarch.rpm A simple API for XML processing
ruby-xml-simple-doc-1.1.5-1.mga6.noarch.rpm Documentation for ruby-xml-simple
ruby-xmlrpc-0.3.0-18.mga7.noarch.rpm XMLRPC is a lightweight protocol that enables remote procedure calls over HTTP
ruby-xpath-3.1.0-1.mga7.noarch.rpm RDoc produces HTML and command-line documentation for Ruby projects
ruby-xpath-doc-3.1.0-1.mga7.noarch.rpm Documentation for ruby-xpath
ruby-yui-1.1.2-3.mga7.i586.rpm Ruby bindings for libyui
ruby-zoom-0.5.0-7.mga7.i586.rpm Ruby Zoom Handler
rubyripper-0.6.2-9.mga6.noarch.rpm A high precision CD ripper
rubyripper-gtk-0.6.2-9.mga6.noarch.rpm GTK frontend for rubyripper
ruli-tools-0.36-12.mga6.i586.rpm Tools utilizing the RULI (Resolver User Layer Interface) library
run-parts-4.8.4-1.mga7.i586.rpm Run scripts or programs in a directory
rust-1.28.0-1.mga7.i586.rpm The Rust Programming Language
rust-analysis-1.28.0-1.mga7.i586.rpm Compiler analysis data for the Rust standard library
rust-debugger-common-1.28.0-1.mga7.noarch.rpm Common debugger pretty printers for Rust
Advertisement
Advertisement