eclipse-egit-5.3.0-1.mga8.noarch.rpm


Advertisement

Description

eclipse-egit - Eclipse Git Integration

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package filename eclipse-egit-5.3.0-1.mga8.noarch.rpm
Package name eclipse-egit
Package version 5.3.0
Package release 1.mga8
Package architecture noarch
Package type rpm
Category Development/Java
Homepage http://www.eclipse.org/egit
License EPL-2.0
Maintainer -
Download size 9.37 MB
Installed size 10.48 MB
The eclipse-egit package contains Eclipse plugins for
interacting with Git repositories.

Alternatives

Package Version Architecture Repository
eclipse-egit-5.3.0-1.mga8.noarch.rpm 5.3.0 noarch Mageia Core
eclipse-egit - - -

Requires

Name Value
eclipse-jgit >= 5.3.0
eclipse-platform >= 1:4.6.0
java-headless >= 1:1.8
javapackages-filesystem -
osgi(org.eclipse.jdt.core) -
osgi(org.eclipse.jdt.launching) -
osgi(org.eclipse.jdt.ui) -
osgi(org.eclipse.jgit) -
osgi(org.eclipse.jgit.junit) -
osgi(org.eclipse.jgit.lfs) -
osgi(org.eclipse.jgit.ssh.apache) -
osgi(org.junit) -

Provides

Name Value
eclipse-egit == 5.3.0-1.mga8
mvn(org.eclipse.egit.feature:org.eclipse.egit) == 5.3.0.201903130848.r
mvn(org.eclipse.egit.feature:org.eclipse.egit.gitflow.feature) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.core) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.core.junit) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.core.junit::sources:) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.core::sources:) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.doc) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.gitflow) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.gitflow.ui) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.gitflow.ui::sources:) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.gitflow::sources:) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.ui) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.ui.smartimport) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.ui.smartimport::sources:) == 5.3.0.201903130848.r
mvn(org.eclipse.egit:org.eclipse.egit.ui::sources:) == 5.3.0.201903130848.r
osgi(org.eclipse.egit) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.core) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.core.junit) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.core.junit.source) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.core.source) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.doc) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.gitflow) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.gitflow.feature) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.gitflow.source) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.gitflow.ui) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.gitflow.ui.source) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.ui) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.ui.smartimport) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.ui.smartimport.source) == 5.3.0.201903130848.r
osgi(org.eclipse.egit.ui.source) == 5.3.0.201903130848.r

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package eclipse-egit-5.3.0-1.mga8.noarch.rpm
Source Package eclipse-egit-5.3.0-1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install eclipse-egit rpm package:
    # urpmi eclipse-egit

Files

Path
/usr/share/doc/eclipse-egit/README.md
/usr/share/eclipse/droplets/egit-egit/fragment.info
/usr/share/eclipse/droplets/egit-egit/features/
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit.gitflow.feature_5.3.0.201903130848-r/epl-2.0.html
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit.gitflow.feature_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit.gitflow.feature_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit.gitflow.feature_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit.gitflow.feature_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit_5.3.0.201903130848-r/epl-2.0.html
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/egit-egit/features/org.eclipse.egit_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/egit-egit/plugins/bcpg_1.61.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/bcpkix_1.61.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/bcprov_1.61.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/com.google.gson_2.8.2.jar
/usr/share/eclipse/droplets/egit-egit/plugins/com.googlecode.javaewah.JavaEWAH_1.1.6.jar
/usr/share/eclipse/droplets/egit-egit/plugins/javax.xml_1.3.4.v201005080400.jar
/usr/share/eclipse/droplets/egit-egit/plugins/net.i2p.crypto.eddsa_0.3.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.apache.sshd.core_2.0.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.apache.sshd.sftp_2.0.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.core.junit.source_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.core.junit_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.core.source_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.core_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.doc_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.gitflow.source_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.gitflow.ui.source_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.gitflow.ui_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.gitflow_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.ui.smartimport.source_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.ui.smartimport_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.ui.source_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit.ui_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.egit_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.jgit.junit_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.jgit.lfs_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.eclipse.jgit_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.hamcrest.core_1.3.0.v201303031735.jar
/usr/share/eclipse/droplets/egit-egit/plugins/org.junit_4.12.0.jar
/usr/share/eclipse/droplets/egit-egit/plugins/slf4j.api_1.7.25.jar
/usr/share/eclipse/droplets/egit-egit/plugins/slf4j.simple_1.7.25.jar
/usr/share/licenses/eclipse-egit/LICENSE
/usr/share/maven-metadata/eclipse-egit-egit.xml

Changelog

2019-07-19 - daviddavid <daviddavid> 5.3.0-1.mga8
+ Revision: 1422712
- Update to 2019-03 release
- Restrict to same architectures as Eclipse itself
2018-12-17 - neoclust <neoclust> 5.2.0-1.mga7
+ Revision: 1342208
- New version 5.2.0
2018-09-18 - umeabot <umeabot> 4.7.0-2.mga7
+ Revision: 1261177
- Mageia 7 Mass Rebuild

See Also

Package Description
eclipse-egit-mylyn-5.3.0-1.mga8.noarch.rpm Git integration for mylyn
eclipse-emf-core-2.16.0-3.mga7.noarch.rpm Eclipse EMF Core Bundles
eclipse-emf-runtime-2.16.0-3.mga7.noarch.rpm Eclipse Modeling Framework (EMF) Eclipse plug-in
eclipse-emf-sdk-2.16.0-3.mga7.noarch.rpm Eclipse EMF and XSD SDK
eclipse-emf-xsd-2.16.0-3.mga7.noarch.rpm XML Schema Definition (XSD) Eclipse plug-in
eclipse-equinox-osgi-4.11-2.mga8.x86_64.rpm Eclipse OSGi - Equinox
eclipse-gef-3.11.0-4.mga8.noarch.rpm Graphical Editing Framework (GEF) Eclipse plug-in
eclipse-gef-sdk-3.11.0-4.mga8.noarch.rpm Eclipse GEF SDK
eclipse-gef-tests-3.11.0-4.mga8.noarch.rpm Eclipse GEF Tests
eclipse-jdt-4.11-2.mga8.noarch.rpm Eclipse Java Development Tools
eclipse-jgit-5.3.0-2.mga8.noarch.rpm Eclipse JGit
eclipse-launchbar-2.2.3-1.mga8.noarch.rpm Eclipse Launchbar plug-in
eclipse-license1-1.0.1-2.mga8.noarch.rpm Shared EPL v1.0 license feature for Eclipse
eclipse-license2-2.0.1-2.mga8.noarch.rpm Shared EPL v2.0 license feature for Eclipse
eclipse-linuxtools-7.2.0-1.mga8.noarch.rpm Linux specific Eclipse plugins
Advertisement
Advertisement