eclipse-jgit-5.3.0-2.mga8.noarch.rpm


Advertisement

Description

eclipse-jgit - Eclipse JGit

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package filename eclipse-jgit-5.3.0-2.mga8.noarch.rpm
Package name eclipse-jgit
Package version 5.3.0
Package release 2.mga8
Package architecture noarch
Package type rpm
Category Development/Java
Homepage http://www.eclipse.org/egit/
License BSD
Maintainer -
Download size 29.62 KB
Installed size 148.37 KB
A pure Java implementation of the Git version control system.

Alternatives

Package Version Architecture Repository
eclipse-jgit-5.3.0-2.mga8.noarch.rpm 5.3.0 noarch Mageia Core
eclipse-jgit - - -

Requires

Name Value
bouncycastle >= 1.61
eclipse-platform -
java-headless -
javapackages-filesystem -
jgit == 5.3.0-2.mga8
jzlib -

Provides

Name Value
eclipse-jgit == 5.3.0-2.mga8
mvn(org.eclipse.jgit.feature:org.eclipse.jgit) == 5.3.0.201903130848.r
mvn(org.eclipse.jgit.feature:org.eclipse.jgit.http.apache) == 5.3.0.201903130848.r
mvn(org.eclipse.jgit.feature:org.eclipse.jgit.junit) == 5.3.0.201903130848.r
mvn(org.eclipse.jgit.feature:org.eclipse.jgit.lfs) == 5.3.0.201903130848.r
mvn(org.eclipse.jgit.feature:org.eclipse.jgit.pgm) == 5.3.0.201903130848.r
mvn(org.eclipse.jgit.feature:org.eclipse.jgit.ssh.apache) == 5.3.0.201903130848.r
osgi(org.eclipse.jgit) == 5.3.0.201903130848.r
osgi(org.eclipse.jgit.http.apache) == 5.3.0.201903130848.r
osgi(org.eclipse.jgit.junit) == 5.3.0.201903130848.r
osgi(org.eclipse.jgit.lfs) == 5.3.0.201903130848.r
osgi(org.eclipse.jgit.pgm) == 5.3.0.201903130848.r
osgi(org.eclipse.jgit.ssh.apache) == 5.3.0.201903130848.r

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package eclipse-jgit-5.3.0-2.mga8.noarch.rpm
Source Package eclipse-jgit-5.3.0-2.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install eclipse-jgit rpm package:
    # urpmi eclipse-jgit

Files

Path
/usr/share/doc/eclipse-jgit/README.md
/usr/share/eclipse/droplets/jgit/fragment.info
/usr/share/eclipse/droplets/jgit/features/
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.http.apache_5.3.0.201903130848-r/edl-v10.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.http.apache_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.http.apache_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.http.apache_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.http.apache_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.junit_5.3.0.201903130848-r/edl-v10.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.junit_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.junit_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.junit_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.junit_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.lfs_5.3.0.201903130848-r/edl-v10.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.lfs_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.lfs_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.lfs_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.lfs_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.pgm_5.3.0.201903130848-r/edl-v10.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.pgm_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.pgm_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.pgm_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.pgm_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r/edl-v10.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit_5.3.0.201903130848-r/edl-v10.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit_5.3.0.201903130848-r/feature.properties
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit_5.3.0.201903130848-r/feature.xml
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit_5.3.0.201903130848-r/license.html
/usr/share/eclipse/droplets/jgit/features/org.eclipse.jgit_5.3.0.201903130848-r/META-INF/MANIFEST.MF
/usr/share/eclipse/droplets/jgit/plugins/bcpg_1.61.0.jar
/usr/share/eclipse/droplets/jgit/plugins/bcpkix_1.61.0.jar
/usr/share/eclipse/droplets/jgit/plugins/bcprov_1.61.0.jar
/usr/share/eclipse/droplets/jgit/plugins/com.google.gson_2.8.2.jar
/usr/share/eclipse/droplets/jgit/plugins/com.googlecode.javaewah.JavaEWAH_1.1.6.jar
/usr/share/eclipse/droplets/jgit/plugins/com.jcraft.jzlib_1.1.3.jar
/usr/share/eclipse/droplets/jgit/plugins/javax.xml_1.3.4.v201005080400.jar
/usr/share/eclipse/droplets/jgit/plugins/net.i2p.crypto.eddsa_0.3.0.jar
/usr/share/eclipse/droplets/jgit/plugins/org.apache.commons.compress_1.18.0.jar
/usr/share/eclipse/droplets/jgit/plugins/org.apache.sshd.core_2.0.0.jar
/usr/share/eclipse/droplets/jgit/plugins/org.apache.sshd.sftp_2.0.0.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.archive_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.http.apache_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.http.server_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.junit.http_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.junit.ssh_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.junit_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.lfs.server_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.lfs_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.pgm_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.ssh.apache_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit.ui_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.eclipse.jgit_5.3.0.201903130848-r.jar
/usr/share/eclipse/droplets/jgit/plugins/org.hamcrest.core_1.3.0.v201303031735.jar
/usr/share/eclipse/droplets/jgit/plugins/org.junit_4.12.0.jar
/usr/share/eclipse/droplets/jgit/plugins/org.kohsuke.args4j_2.33.0.jar
/usr/share/eclipse/droplets/jgit/plugins/slf4j.api_1.7.25.jar
/usr/share/eclipse/droplets/jgit/plugins/slf4j.simple_1.7.25.jar
/usr/share/licenses/eclipse-jgit/LICENSE
/usr/share/maven-metadata/eclipse-jgit.xml

Changelog

2019-07-19 - daviddavid <daviddavid> 5.3.0-2.mga8
+ Revision: 1422720
- Non-boostrap build
2019-07-19 - daviddavid <daviddavid> 5.3.0-1.mga8
+ Revision: 1422710
- Update to 2019-03 release
- Restrict to same architectures as Eclipse itself
- bootstrap build
2019-07-18 - daviddavid <daviddavid> 5.2.0-4.mga8
+ Revision: 1422348
- Add javapackages-tools requires to jgit for /usr/bin/build-classpath
2019-02-07 - daviddavid <daviddavid> 5.2.0-3.mga7
+ Revision: 1363962
- Add missing requires for optional dep on bouncycastle
2018-12-16 - neoclust <neoclust> 5.2.0-2.mga7
+ Revision: 1341798
- Disable bootstrap
2018-12-15 - neoclust <neoclust> 5.2.0-1.mga7
+ Revision: 1341389
- New version 5.2.0
2018-09-18 - umeabot <umeabot> 4.7.0-4.mga7
+ Revision: 1260749
- Mageia 7 Mass Rebuild

See Also

Package Description
eclipse-launchbar-2.2.3-1.mga8.noarch.rpm Eclipse Launchbar plug-in
eclipse-license1-1.0.1-2.mga8.noarch.rpm Shared EPL v1.0 license feature for Eclipse
eclipse-license2-2.0.1-2.mga8.noarch.rpm Shared EPL v2.0 license feature for Eclipse
eclipse-linuxtools-7.2.0-1.mga8.noarch.rpm Linux specific Eclipse plugins
eclipse-linuxtools-changelog-7.2.0-1.mga8.noarch.rpm Eclipse ChangeLog plug-in
eclipse-linuxtools-docker-7.2.0-1.mga8.noarch.rpm Docker Tooling
eclipse-linuxtools-gcov-7.2.0-1.mga8.noarch.rpm GCov Integration
eclipse-linuxtools-gprof-7.2.0-1.mga8.noarch.rpm GProf Integration
eclipse-linuxtools-javadocs-7.2.0-1.mga8.noarch.rpm Javadocs documentation plugin for Eclipse
eclipse-linuxtools-libhover-7.2.0-1.mga8.noarch.rpm Libhover documentation plugin for Eclipse
eclipse-linuxtools-manpage-7.2.0-1.mga8.noarch.rpm Man page viewer
eclipse-linuxtools-perf-7.2.0-1.mga8.noarch.rpm Eclipse plugin for Perf integration
eclipse-linuxtools-rpm-editor-7.2.0-1.mga8.noarch.rpm RPM Spec file editor for Eclipse
eclipse-linuxtools-systemtap-7.2.0-1.mga8.noarch.rpm Systemtap Tools Integration for Eclipse
eclipse-linuxtools-tests-7.2.0-1.mga8.noarch.rpm Linux Tools Project Test Bundles
Advertisement
Advertisement