lib64ncurses6-6.1-20190817.1.mga8.x86_64.rpm


Advertisement

Description

lib64ncurses6 - The development files for applications which use ncurses

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package filename lib64ncurses6-6.1-20190817.1.mga8.x86_64.rpm
Package name lib64ncurses6
Package version 6.1
Package release 20190817.1.mga8
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.gnu.org/software/ncurses/ncurses.html
License MIT
Maintainer -
Download size 218.24 KB
Installed size 627.60 KB
The curses library routines are a terminal-independent method of updating
character screens with reasonalble optimization. The ncurses (new curses)
library is a freely distributable replacement for the discontinued 4.4BSD
classic curses library.

Alternatives

Package Version Architecture Repository
lib64ncurses6 - - -

Requires

Name Value
filesystem >= 2.1.9-18
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.16)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libform.so.6()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libmenu.so.6()(64bit) -
libncurses.so.6()(64bit) -
libpanel.so.6()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libtinfo.so.6()(64bit) -

Provides

Name Value
lib64ncurses6 == 6.1-20190817.1.mga8
lib64ncurses6(x86-64) == 6.1-20190817.1.mga8
libform.so.6()(64bit) -
libmenu.so.6()(64bit) -
libncurses++.so.6()(64bit) -
libncurses.so.6()(64bit) -
libpanel.so.6()(64bit) -
libtic.so.6()(64bit) -
libtinfo.so.6()(64bit) -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64ncurses6-6.1-20190817.1.mga8.x86_64.rpm
Source Package ncurses-6.1-20190817.1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64ncurses6 rpm package:
    # urpmi lib64ncurses6

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/16/e0d47c4e7e2c94bed484a764fbb1af61b204e4
/usr/lib/.build-id/33/e0b8e0b901a77878ec2f06d62a845c4a17d43f
/usr/lib/.build-id/57/7434332b9ae29d7a0fe0ce65bf0d703f8cf952
/usr/lib/.build-id/65/f8ee7487e303762cbc2ab311f73ed69f22d7a2
/usr/lib/.build-id/7c/20173e8e6c1ace7fd804424037782e5ddaa2ef
/usr/lib/.build-id/ac/d73024f7565d978bcd00d551c555818850348e
/usr/lib/.build-id/ca/7489284a733f6cf5b64a2e353d13f1a1117713
/usr/lib64/libform.so.6
/usr/lib64/libform.so.6.1
/usr/lib64/libmenu.so.6
/usr/lib64/libmenu.so.6.1
/usr/lib64/libncurses++.so.6
/usr/lib64/libncurses++.so.6.1
/usr/lib64/libncurses.so.6
/usr/lib64/libncurses.so.6.1
/usr/lib64/libpanel.so.6
/usr/lib64/libpanel.so.6.1
/usr/lib64/libtic.so.6
/usr/lib64/libtic.so.6.1
/usr/lib64/libtinfo.so.6
/usr/lib64/libtinfo.so.6.1

Changelog

2019-08-25 - wally <wally> 6.1-20190817.1.mga8
+ Revision: 1432094
- new version 6.1-20190817
2018-12-01 - wally <wally> 6.1-20181117.3.mga7
+ Revision: 1337082
- drop --disable-relink configure switch
- install wide-character versions of libtinfo and libtic
- drop static build
- don't strip binaries
2018-11-25 - wally <wally> 6.1-20181117.2.mga7
+ Revision: 1334185
- disable shared lib relinking during install (when building the pkg)
2018-11-25 - daviddavid <daviddavid> 6.1-20181117.1.mga7
+ Revision: 1333979
- new version 6.1-20181117
2018-09-23 - umeabot <umeabot> 6.1-20180728.2.mga7
+ Revision: 1299686
- Mageia 7 Mass Rebuild
2018-08-04 - wally <wally> 6.1-20180728.1.mga7
+ Revision: 1247246
- new version 6.1-20180728
2018-05-28 - wally <wally> 6.1-20180526.1.mga7
+ Revision: 1232790
- update to 6.1-20180526
2018-04-12 - kekepower <kekepower> 6.1-20180407.1.mga7
+ Revision: 1218021
- Update to 6.1-20180407
- Fix make commands
2018-03-18 - joequant <joequant> 6.1-20180317.1.mga7
+ Revision: 1210288
- upgrade to 6.1
+ wally <wally>
- fix also ncursesw devel provides on aarch64
2018-02-27 - wally <wally> 6.0-20171223.4.mga7
+ Revision: 1205482
- fix devel pkg provides on aarch64

See Also

Package Description
lib64ncursesw-devel-6.1-20190817.1.mga8.x86_64.rpm The development files for applications which use ncurses
lib64ncursesw5-6.1-20190817.1.mga8.x86_64.rpm Ncurses libraries which support UTF8
lib64ncursesw6-6.1-20190817.1.mga8.x86_64.rpm Ncurses libraries which support UTF8
lib64ndctl-devel-63-3.mga7.x86_64.rpm Development files for libndctl
lib64ndctl6-63-3.mga7.x86_64.rpm Management library for "libnvdimm" subsystem devices (Non-volatile Memory)
lib64ndp-devel-1.6-3.mga7.x86_64.rpm Libraries and header files for libndp development
lib64ndp0-1.6-3.mga7.x86_64.rpm Library for Neighbor Discovery Protocol
lib64ndpi-devel-2.6-1.mga7.x86_64.rpm Header files and libraries for developing applications for nDPI
lib64ndpi-static-devel-2.6-1.mga7.x86_64.rpm Open source deep packet inspection static library
lib64ndpi2-2.6-1.mga7.x86_64.rpm Open source deep packet inspection library
lib64nemo-devel-4.2.3-1.mga8.x86_64.rpm Support for developing nemo extensions
lib64nemo-extension-4.2.3-1.mga8.x86_64.rpm Nemo extensions library
lib64nemo-gir3.0-4.2.3-1.mga8.x86_64.rpm GObject Introspection interface description for nemo
lib64neon-devel-0.30.2-2.mga7.x86_64.rpm Headers for developing programs that will use libneon
lib64neon-static-devel-0.30.2-2.mga7.x86_64.rpm Static libneon library
Advertisement
Advertisement