lib64qt5sql-devel-5.11.2-2.mga7.x86_64.rpm


Advertisement

Description

lib64qt5sql-devel - Devel files needed to build apps based on QtSql

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package name lib64qt5sql-devel
Package version 5.11.2
Package release 2.mga7
Package architecture x86_64
Package type rpm
Installed size 97.73 KB
Download size 32.04 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Devel files needed to build apps based on QtSql.

Alternatives

Package Version Architecture Repository
lib64qt5sql-devel-5.12.0-1.mga7.x86_64.rpm 5.12.0 x86_64 Mageia Core Updates Testing
lib64qt5sql-devel - - -

Requires

Name Value
devel(libQt5Core(64bit)) -
devel(libstdc++(64bit)) -
lib64qt5sql5 == 5.11.2
pkgconfig -
pkgconfig(Qt5Core) -
qtbase5-common == 5.11.2
qtbase5-common-devel == 5.11.2-2.mga7
qtbase5-database-plugin mysql
qtbase5-database-plugin odbc
qtbase5-database-plugin pgsql
qtbase5-database-plugin sqlite
qtbase5-database-plugin tds

Provides

Name Value
cmake(Qt5Sql) == 5.11.2
devel(libQt5Sql(64bit)) -
lib64qt5sql-devel == 5.11.2-2.mga7
lib64qt5sql-devel(x86-64) == 5.11.2-2.mga7
lib64qt5sql-private-devel == 5.11.2-2.mga7
libqt5sql-devel == 5.11.2
libqt5sql-private-devel == 5.11.2
libqtsql5-devel == 5.11.2
libqtsql5-private-devel == 5.11.2
pkgconfig(Qt5Sql) == 5.11.2
qt5sql-devel == 5.11.2
qt5sql-private-devel == 5.11.2
qtsql5-devel == 5.11.2
qtsql5-private-devel == 5.11.2

Obsoletes

Name Value
lib64qt5sql-private-devel < 5.6.0-1

Download

Type URL
Binary Package lib64qt5sql-devel-5.11.2-2.mga7.x86_64.rpm
Source Package qtbase5-5.11.2-2.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64qt5sql-devel rpm package:
    # urpmi lib64qt5sql-devel

Files

Path
/usr/lib64/libQt5Sql.prl
/usr/lib64/libQt5Sql.so
/usr/lib64/cmake/Qt5Sql/Qt5SqlConfig.cmake
/usr/lib64/cmake/Qt5Sql/Qt5SqlConfigVersion.cmake
/usr/lib64/cmake/Qt5Sql/Qt5Sql_QMYSQLDriverPlugin.cmake
/usr/lib64/cmake/Qt5Sql/Qt5Sql_QODBCDriverPlugin.cmake
/usr/lib64/cmake/Qt5Sql/Qt5Sql_QPSQLDriverPlugin.cmake
/usr/lib64/cmake/Qt5Sql/Qt5Sql_QSQLiteDriverPlugin.cmake
/usr/lib64/cmake/Qt5Sql/Qt5Sql_QTDSDriverPlugin.cmake
/usr/lib64/pkgconfig/Qt5Sql.pc
/usr/lib64/qt5/include/QtSql/QSql
/usr/lib64/qt5/include/QtSql/QSqlDatabase
/usr/lib64/qt5/include/QtSql/QSqlDriver
/usr/lib64/qt5/include/QtSql/QSqlDriverCreator
/usr/lib64/qt5/include/QtSql/QSqlDriverCreatorBase
/usr/lib64/qt5/include/QtSql/QSqlDriverPlugin
/usr/lib64/qt5/include/QtSql/QSqlError
/usr/lib64/qt5/include/QtSql/QSqlField
/usr/lib64/qt5/include/QtSql/QSqlIndex
/usr/lib64/qt5/include/QtSql/QSqlQuery
/usr/lib64/qt5/include/QtSql/QSqlQueryModel
/usr/lib64/qt5/include/QtSql/QSqlRecord
/usr/lib64/qt5/include/QtSql/QSqlRelation
/usr/lib64/qt5/include/QtSql/QSqlRelationalDelegate
/usr/lib64/qt5/include/QtSql/QSqlRelationalTableModel
/usr/lib64/qt5/include/QtSql/QSqlResult
/usr/lib64/qt5/include/QtSql/QSqlTableModel
/usr/lib64/qt5/include/QtSql/QtSql
/usr/lib64/qt5/include/QtSql/QtSqlDepends
/usr/lib64/qt5/include/QtSql/QtSqlVersion
/usr/lib64/qt5/include/QtSql/qsql.h
/usr/lib64/qt5/include/QtSql/qsqldatabase.h
/usr/lib64/qt5/include/QtSql/qsqldriver.h
/usr/lib64/qt5/include/QtSql/qsqldriverplugin.h
/usr/lib64/qt5/include/QtSql/qsqlerror.h
/usr/lib64/qt5/include/QtSql/qsqlfield.h
/usr/lib64/qt5/include/QtSql/qsqlindex.h
/usr/lib64/qt5/include/QtSql/qsqlquery.h
/usr/lib64/qt5/include/QtSql/qsqlquerymodel.h
/usr/lib64/qt5/include/QtSql/qsqlrecord.h
/usr/lib64/qt5/include/QtSql/qsqlrelationaldelegate.h
/usr/lib64/qt5/include/QtSql/qsqlrelationaltablemodel.h
/usr/lib64/qt5/include/QtSql/qsqlresult.h
/usr/lib64/qt5/include/QtSql/qsqltablemodel.h
/usr/lib64/qt5/include/QtSql/qtsqlglobal.h
/usr/lib64/qt5/include/QtSql/qtsqlversion.h
/usr/lib64/qt5/include/QtSql/5.11.2/
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qsqlcachedresult_p.h
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qsqldriver_p.h
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qsqlnulldriver_p.h
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qsqlquerymodel_p.h
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qsqlresult_p.h
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qsqltablemodel_p.h
/usr/lib64/qt5/include/QtSql/5.11.2/QtSql/private/qtsqlglobal_p.h

Changelog

2018-11-18 - tv <tv> 5.11.2-2.mga7
+ Revision: 1330684
- link moc & co in /bin with -qt5 prefix the FC way (needed for LO)
2018-10-15 - neoclust <neoclust> 5.11.2-1.mga7
+ Revision: 1320464
- New version 5.11.2
2018-09-23 - umeabot <umeabot> 5.11.1-3.mga7
+ Revision: 1300693
- Mageia 7 Mass Rebuild
2018-08-21 - tv <tv> 5.11.1-2.mga7
+ Revision: 1253270
- rebuild with latest icu
2018-07-29 - neoclust <neoclust> 5.11.1-1.mga7
+ Revision: 1245802
- New version 5.11.1
2018-06-26 - daviddavid <daviddavid> 5.11.0-3.mga7
+ Revision: 1239750
- compile against openssl 1.1
2018-05-28 - neoclust <neoclust> 5.11.0-2.mga7
+ Revision: 1232799
- Non bootstrap build
2018-05-25 - neoclust <neoclust> 5.11.0-1.mga7
+ Revision: 1232155
- New version 5.11.0
2018-04-21 - daviddavid <daviddavid> 5.10.1-5.mga7
+ Revision: 1220660
- non bootstrap build
2018-04-20 - daviddavid <daviddavid> 5.10.1-4.mga7
+ Revision: 1220513
- bootstrap build for arm now (because of broken tslib)

See Also

Package Description
lib64qt5sql5-5.11.2-2.mga7.x86_64.rpm Qt5 SQL Library
lib64qt5svg-devel-5.11.2-1.mga7.x86_64.rpm Devel files needed to build apps based on QtSvg
lib64qt5svg5-5.11.2-1.mga7.x86_64.rpm Qt5 Component Library
lib64qt5test-devel-5.11.2-2.mga7.x86_64.rpm Devel files needed to build apps based on QtTest
lib64qt5test5-5.11.2-2.mga7.x86_64.rpm Qt5 Test Library
lib64qt5texttospeech-devel-5.11.2-1.mga7.x86_64.rpm Devel files needed to build apps based on QtTextToSpeech
lib64qt5texttospeech5-5.11.2-1.mga7.x86_64.rpm Qt5 TextToSpeech Component Library
lib64qt5themesupport-static-devel-5.11.2-2.mga7.x86_64.rpm Devel files needed to build apps based on ThemeSupport
lib64qt5virtualkeyboard-devel-5.11.2-4.mga7.x86_64.rpm Devel files needed to build apps based on QtVirtualKeyboard
lib64qt5waylandclient-devel-5.11.2-1.mga7.x86_64.rpm Devel files needed to build apps based on QtWayland
lib64qt5waylandclient5-5.11.2-1.mga7.x86_64.rpm Qt5 WaylandClient Component Library
lib64qt5waylandcompositor5-5.11.2-1.mga7.x86_64.rpm Qt5 WaylandCompositor Component Library
lib64qt5webchannel-devel-5.11.2-1.mga7.x86_64.rpm Devel files needed to build apps based on qtwebchannel5
lib64qt5webchannel5-5.11.2-1.mga7.x86_64.rpm Qt5 Component Library
lib64qt5webengine-devel-5.11.2-1.mga7.x86_64.rpm Devel files needed to build apps based on qtwebengine5
Advertisement
Advertisement