python3-boost-openmpi-1.72.0-1.mga8.x86_64.rpm


Advertisement

Description

python3-boost-openmpi - Python 3 bindings for Boost.MPI-OpenMPI library

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package filename python3-boost-openmpi-1.72.0-1.mga8.x86_64.rpm
Package name python3-boost-openmpi
Package version 1.72.0
Package release 1.mga8
Package architecture x86_64
Package type rpm
Category Development/Python
Homepage http://www.boost.org
License Boost and MIT and Python
Maintainer -
Download size 166.74 KB
Installed size 482.85 KB
This package contains the Boost.MPI-OpenMPI bindings for Python 3.

Alternatives

Package Version Architecture Repository
python3-boost-openmpi-1.72.0-1.mga8.i586.rpm 1.72.0 i586 Mageia Core
python3-boost-openmpi - - -

Requires

Name Value
libboost_mpi.so.1.72.0()(64bit) -
libboost_mpi_python38.so.1.72.0()(64bit) -
libboost_python38.so.1.72.0()(64bit) -
libboost_serialization.so.1.72.0()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libmpi.so.40()(64bit) -
libmpi_cxx.so.40()(64bit) -
libpython3.8.so.1.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
python(abi) == 3.8

Provides

Name Value
python3-boost-openmpi == 1.72.0-1.mga8
python3-boost-openmpi(x86-64) == 1.72.0-1.mga8

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package python3-boost-openmpi-1.72.0-1.mga8.x86_64.rpm
Source Package boost-1.72.0-1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install python3-boost-openmpi rpm package:
    # urpmi python3-boost-openmpi

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/52/3979be0307ed14f6a65690add0be2dd3e8deef
/usr/lib64/python3.8/site-packages/boost/__init__.py
/usr/lib64/python3.8/site-packages/boost/__pycache__/__init__.cpython-38.opt-1.pyc
/usr/lib64/python3.8/site-packages/boost/__pycache__/__init__.cpython-38.pyc
/usr/lib64/python3.8/site-packages/boost/openmpi/__init__.py
/usr/lib64/python3.8/site-packages/boost/openmpi/mpi.so
/usr/lib64/python3.8/site-packages/boost/openmpi/__pycache__/__init__.cpython-38.opt-1.pyc
/usr/lib64/python3.8/site-packages/boost/openmpi/__pycache__/__init__.cpython-38.pyc

Changelog

2020-01-26 - wally <wally> 1.72.0-1.mga8
+ Revision: 1483313
- new version 1.72.0
- add lzma and zstd support
- rediff patches
- add patch originally from openSUSE to build shared libs
- add patch to fix overlinking and mysterious mpi build error
2019-10-05 - daviddavid <daviddavid> 1.68.0-7.mga8
+ Revision: 1449434
- rebuild for new icu 65.1
2019-09-04 - wally <wally> 1.68.0-6.mga8
+ Revision: 1437125
- turn off the brp-python-bytecompile automagic
- fix python requires
- rebuild for python3.8
- disable python2 support
+ tmb <tmb>
- lib(64)boost-devel: only recommend lib(64)boost_python2-devel
2019-01-07 - tv <tv> 1.68.0-4.mga7
+ Revision: 1350502
- rebuild with python 3.7
2018-12-29 - luigiwalser <luigiwalser> 1.68.0-3.mga7
+ Revision: 1346086
- rebuild for icu
2018-10-17 - wally <wally> 1.68.0-2.mga7
+ Revision: 1321690
- remove precompiled code from examples
2018-10-16 - wally <wally> 1.68.0-1.mga7
+ Revision: 1320999
- add conflicts for OpenMPI/MPICH Parallel BGL graph libraries
- update descriptions/summaries
- update libboost_graph_parallel lib pkg names
- split out openmpi/mpich python modules
- install openmpi/mpich libs to /usr/lib{,64}
- update openmpi/mpich pkg descriptions and summaries
2018-10-13 - wally <wally> 1.68.0-0.3.mga7
+ Revision: 1320082
- rely on autogenerated requires in openmpi and mpich pkgs
2018-10-13 - wally <wally> 1.68.0-0.2.mga7
+ Revision: 1320074
- fix Parallel BGL graph library pkg names
2018-10-13 - wally <wally> 1.68.0-0.1.mga7
+ Revision: 1320042
- new version 1.68.0
- sync .spec and patches with Fedora where appropriate
- disable mpich support as we can't have both mpich and openmpi devel pkgs installed at the same time

See Also

Package Description
python3-botan-1.10.17-10.mga8.x86_64.rpm Python3 bindings for botan
python3-botan2-2.13.0-2.mga8.x86_64.rpm Python3 bindings for botan2
python3-boto-2.49.0-2.mga8.noarch.rpm A simple lightweight interface to Amazon Web Services
python3-boto-2.49.0-3.mga8.noarch.rpm A simple lightweight interface to Amazon Web Services
python3-boto3-1.10.21-1.mga8.noarch.rpm The AWS SDK for Python 3
python3-boto3-1.10.21-2.mga8.noarch.rpm The AWS SDK for Python 3
python3-botocore-1.13.21-1.mga8.noarch.rpm The low-level, core functionality of boto 3
python3-botocore-1.13.21-2.mga8.noarch.rpm The low-level, core functionality of boto 3
python3-bottle-0.12.17-1.mga8.noarch.rpm Fast and simple WSGI-framework for small web-applications
python3-bottle-0.12.17-2.mga8.noarch.rpm Fast and simple WSGI-framework for small web-applications
python3-bottleneck-1.2.1-4.mga8.x86_64.rpm Fast NumPy array functions written in C
python3-brlapi-5.5-9.mga8.x86_64.rpm Python 3 bindings for BrlAPI
python3-brotli-1.0.7-4.mga8.x86_64.rpm Python3 module for brotli
python3-brotlipy-0.7.0-5.mga8.x86_64.rpm Python 3 binding to the Brotli library
python3-bsddb3-6.2.6-6.mga8.x86_64.rpm Python 3 bindings for BerkeleyDB
Advertisement
Advertisement