python3-neovim-0.3.0-1.mga7.noarch.rpm


Advertisement

Description

python3-neovim - Python client for Neovim

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package name python3-neovim
Package version 0.3.0
Package release 1.mga7
Package architecture noarch
Package type rpm
Installed size 217.50 KB
Download size 72.79 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Implements support for python plugins in Nvim. Also works as a library for
connecting to and scripting Nvim processes through its msgpack-rpc API.

Alternatives

Package Version Architecture Repository
python3-neovim-0.3.0-1.mga7.noarch.rpm 0.3.0 noarch Mageia Core
python3-neovim - - -

Requires

Name Value
neovim -
python(abi) == 3.6
python3.6dist(greenlet) -
python3.6dist(msgpack) >= 0.5.0

Provides

Name Value
python3-neovim == 0.3.0-1.mga7
python3.6dist(neovim) == 0.3.0
python3dist(neovim) == 0.3.0
pythonegg(3)(neovim) == 0.3.0

Download

Type URL
Binary Package python3-neovim-0.3.0-1.mga7.noarch.rpm
Source Package python-neovim-0.3.0-1.mga7.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install python3-neovim rpm package:
    # urpmi python3-neovim

Files

Path
/usr/lib/python3.6/site-packages/neovim/__init__.py
/usr/lib/python3.6/site-packages/neovim/compat.py
/usr/lib/python3.6/site-packages/neovim/util.py
/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/not-zip-safe
/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/requires.txt
/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/neovim/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/__pycache__/compat.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/__pycache__/compat.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/__pycache__/util.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/__pycache__/util.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__init__.py
/usr/lib/python3.6/site-packages/neovim/api/buffer.py
/usr/lib/python3.6/site-packages/neovim/api/common.py
/usr/lib/python3.6/site-packages/neovim/api/nvim.py
/usr/lib/python3.6/site-packages/neovim/api/tabpage.py
/usr/lib/python3.6/site-packages/neovim/api/window.py
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/buffer.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/buffer.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/common.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/common.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/nvim.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/nvim.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/tabpage.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/tabpage.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/window.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/window.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__init__.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/async_session.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/msgpack_stream.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/session.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/async_session.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/async_session.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/msgpack_stream.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/msgpack_stream.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/session.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/__pycache__/session.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__init__.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/asyncio.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/base.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/uv.py
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/asyncio.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/asyncio.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/base.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/base.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/uv.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/msgpack_rpc/event_loop/__pycache__/uv.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__init__.py
/usr/lib/python3.6/site-packages/neovim/plugin/decorators.py
/usr/lib/python3.6/site-packages/neovim/plugin/host.py
/usr/lib/python3.6/site-packages/neovim/plugin/script_host.py
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/decorators.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/decorators.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/host.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/host.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/script_host.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/plugin/__pycache__/script_host.cpython-36.pyc
/usr/share/doc/python3-neovim/README.md
/usr/share/licenses/python3-neovim/LICENSE

Changelog

2018-11-14 - kekepower <kekepower> 0.3.0-1.mga7
+ Revision: 1329930
- Update to version 0.3.0
2018-09-20 - umeabot <umeabot> 0.2.6-2.mga7
+ Revision: 1289478
- Mageia 7 Mass Rebuild
2018-05-04 - kekepower <kekepower> 0.2.6-1.mga7
+ Revision: 1226227
- Update to version 0.2.6
2018-03-16 - kekepower <kekepower> 0.2.4-1.mga7
+ Revision: 1209867
- Update to version 0.2.4
2018-03-02 - kekepower <kekepower> 0.2.3-1.mga7
+ Revision: 1206086
- Update to version 0.2.3
2018-02-09 - kekepower <kekepower> 0.2.1-5.mga7
+ Revision: 1199956
- Rebuild for new python-msgpack
2018-02-09 - kekepower <kekepower> 0.2.1-4.mga7
+ Revision: 1199856
- Using %define __python_requires %{nil} to supress warning during install
2018-02-09 - kekepower <kekepower> 0.2.1-3.mga7
+ Revision: 1199852
- Require minimum version 0.5.0 of python-msgpack
2018-02-09 - kekepower <kekepower> 0.2.1-2.mga7
+ Revision: 1199820
- Rebuild against new python-msgpack
2018-02-08 - kekepower <kekepower> 0.2.1-1.mga7
+ Revision: 1199759
- Update to version 0.2.1

See Also

Package Description
python3-neovim-remote-2.1.1-2.mga7.noarch.rpm Control nvim processes using "nvr" commandline tool
python3-netaddr-0.7.18-4.mga7.noarch.rpm Pythonic manipulation of IPv4, IPv6, CIDR, EUI and MAC network addresses
python3-netcdf4-1.4.0-3.mga7.x86_64.rpm Python3/numpy interface to netCDF
python3-netifaces-0.10.6-3.mga7.x86_64.rpm Portable network interface information
python3-networkx-1.11-4.mga7.noarch.rpm Python 3 package for the study of complex networks
python3-neurolab-0.3.5-5.mga7.noarch.rpm Simple and powerfull neural network library for python
python3-newt-0.52.20-8.mga7.x86_64.rpm Python 3 library for Newt windowing toolkit
python3-nose-1.3.7-8.mga7.noarch.rpm Discovery-based unittest extension for Python 3
python3-nosexcover-1.0.11-2.mga7.noarch.rpm Extends nose.plugins.cover to add Cobertura-style XML reports
python3-nox-automation-0.19.1-2.mga7.noarch.rpm Flexible test automation
python3-num2words-0.5.6-2.mga7.noarch.rpm Modules to convert numbers to words
python3-numexpr-2.6.8-2.mga7.x86_64.rpm Fast numerical array expression evaluator for Python3 and NumPy
python3-numpy-1.15.0-2.mga7.x86_64.rpm A fast multidimensional array facility for Python3
python3-numpy-devel-1.15.0-2.mga7.x86_64.rpm Numpy headers for Python3
python3-numpy-f2py-1.15.0-2.mga7.x86_64.rpm f2py for numpy
Advertisement
Advertisement