tomcat-el-3.0-api-9.0.30-1.mga8.noarch.rpm


Advertisement

Description

tomcat-el-3.0-api - Apache Tomcat Expression Language v3.0 API Implementation Classes

Property Value
Distribution Mageia Cauldron
Repository Mageia Core x86_64
Package filename tomcat-el-3.0-api-9.0.30-1.mga8.noarch.rpm
Package name tomcat-el-3.0-api
Package version 9.0.30
Package release 1.mga8
Package architecture noarch
Package type rpm
Category Development/Java
Homepage http://tomcat.apache.org/
License ASL 2.0
Maintainer -
Download size 104.56 KB
Installed size 146.95 KB
Apache Tomcat EL API Implementation Classes.

Alternatives

Package Version Architecture Repository
tomcat-el-3.0-api-9.0.30-1.mga8.noarch.rpm 9.0.30 noarch Mageia Core
tomcat-el-3.0-api-9.0.26-1.mga8.noarch.rpm 9.0.26 noarch Mageia Core
tomcat-el-3.0-api - - -

Requires

Name Value
java-headless -
javapackages-filesystem -

Provides

Name Value
el_api == 3.0
mvn(org.apache.tomcat:tomcat-el-api) == 9.0.30
mvn(org.apache.tomcat:tomcat-el-api:pom:) == 9.0.30
mvn(org.eclipse.jetty.orbit:javax.el) == 9.0.30
mvn(org.eclipse.jetty.orbit:javax.el:pom:) == 9.0.30
osgi(org.apache.tomcat-el-api) == 9.0.30
tomcat-el-3.0-api == 1:9.0.30-1.mga8

Obsoletes

Name Value
tomcat-el-2.2-api -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package tomcat-el-3.0-api-9.0.30-1.mga8.noarch.rpm
Source Package tomcat-9.0.30-1.mga8.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install tomcat-el-3.0-api rpm package:
    # urpmi tomcat-el-3.0-api

Files

Path
/usr/share/doc/tomcat-el-3.0-api/LICENSE
/usr/share/java/tomcat-el-3.0-api.jar
/usr/share/java/tomcat-el-api.jar
/usr/share/java/tomcat/tomcat-el-3.0-api.jar
/usr/share/maven-metadata/tomcat-tomcat-el-api.xml
/usr/share/maven-poms/JPP-tomcat-el-api.pom

Changelog

2020-01-21 - daviddavid <daviddavid> 1:9.0.30-1.mga8
+ Revision: 1481892
- new version: 9.0.30, fixes CVE-2019-12418 and CVE-2019-17563 (mga#25987)
2019-10-02 - daviddavid <daviddavid> 1:9.0.26-1.mga8
+ Revision: 1448725
- new version: 9.0.26
- Resolves: rhbz#1523112 tomcat systemd does not cope with - in service names
- Resolves: rhbz#1510896 Problem to start tomcat with a user whose group has a name different to the user
2019-07-05 - daviddavid <daviddavid> 1:9.0.21-1.mga8
+ Revision: 1418726
- new version: 9.0.21 (sync with fc 31)
2018-12-15 - daviddavid <daviddavid> 1:9.0.13-1.mga7
+ Revision: 1341345
- new version: 9.0.13, fixes CVE-2018-11784
2018-12-05 - daviddavid <daviddavid> 1:9.0.10-1.mga7
+ Revision: 1338423
- new version: 9.0.10 (sync with fc29)
* CVE-2018-1336 tomcat: A bug in the UTF-8 decoder can lead to DoS
* CVE-2018-8014 tomcat: Insecure defaults in CORS filter enable 'supportsCredentials' for all origins
* CVE-2018-8034 tomcat: host name verification missing in WebSocket client
* CVE-2018-8037 tomcat: Due to a mishandling of close in NIO/NIO2 connectors user sessions     can get mixed up
2018-09-21 - umeabot <umeabot> 1:8.0.50-2.mga7
+ Revision: 1291867
- Mageia 7 Mass Rebuild
2018-02-25 - daviddavid <daviddavid> 1:8.0.50-1.mga7
+ Revision: 1204886
- new version: 8.0.50, fixes CVE-2018-1304 and CVE-2018-1305 (mga#22644)
2018-02-01 - daviddavid <daviddavid> 1:8.0.49-1.mga7
+ Revision: 1198447
- change "zip -u" to "zip"
- resolves: rhbz#1495241 [tomcat] zip -u in spec file causes race condition
- The tomcat-native binary is no longer copied to bin. See http://svn.apache.org/r1818186
- new version: 8.0.49

See Also

Package Description
tomcat-jsp-2.3-api-9.0.26-1.mga8.noarch.rpm Apache Tomcat JavaServer Pages v2.3 API Implementation Classes
tomcat-jsp-2.3-api-9.0.30-1.mga8.noarch.rpm Apache Tomcat JavaServer Pages v2.3 API Implementation Classes
tomcat-jsvc-9.0.26-1.mga8.noarch.rpm Apache jsvc wrapper for Apache Tomcat as separate service
tomcat-jsvc-9.0.30-1.mga8.noarch.rpm Apache jsvc wrapper for Apache Tomcat as separate service
tomcat-lib-9.0.26-1.mga8.noarch.rpm Libraries needed to run the Tomcat Web container
tomcat-lib-9.0.30-1.mga8.noarch.rpm Libraries needed to run the Tomcat Web container
tomcat-native-1.2.23-2.mga8.x86_64.rpm Tomcat native library
tomcat-servlet-4.0-api-9.0.26-1.mga8.noarch.rpm Apache Tomcat Java Servlet v4.0 API Implementation Classes
tomcat-servlet-4.0-api-9.0.30-1.mga8.noarch.rpm Apache Tomcat Java Servlet v4.0 API Implementation Classes
tomcat-taglibs-parent-3-7.mga7.noarch.rpm Apache Taglibs Parent
tomcat-taglibs-parent-3-8.mga8.noarch.rpm Apache Taglibs Parent
tomcat-taglibs-standard-1.2.5-4.mga7.noarch.rpm Apache Standard Taglib
tomcat-taglibs-standard-1.2.5-5.mga8.noarch.rpm Apache Standard Taglib
tomcat-taglibs-standard-javadoc-1.2.5-4.mga7.noarch.rpm Javadoc for tomcat-taglibs-standard
tomcat-taglibs-standard-javadoc-1.2.5-5.mga8.noarch.rpm Javadoc for tomcat-taglibs-standard
Advertisement
Advertisement